Dependency Convergence

Legend:
[Error]
At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of dependencies (NOD): 66
Number of unique artifacts (NOA): 77
Number of version-conflicting artifacts (NOC): 7
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA):
[Error]
 85 %
Ready for release (100% convergence and no SNAPSHOTS):
[Error]
 Error
You do not have 100% convergence.

Dependencies used in this project

com.google.guava:guava

[Error]
25.1-android
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    \- org.apache.maven:maven-core:jar:3.6.3:provided
       \- com.google.inject:guice:jar:no_aop:4.2.1:provided
          \- (com.google.guava:guava:jar:25.1-android:provided - omitted for conflict with 29.0-jre)

29.0-jre
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    \- com.google.guava:guava:jar:29.0-jre:compile

junit:junit

[Error]
4.11
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    \- io.takari.maven.plugins:takari-plugin-testing:jar:2.9.2:test
       \- (junit:junit:jar:4.11:test - omitted for conflict with 4.12)

4.12
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    \- junit:junit:jar:4.12:test

4.13
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    \- org.junit.vintage:junit-vintage-engine:jar:5.7.0:test
       \- (junit:junit:jar:4.13:test - omitted for conflict with 4.12)

org.apache.maven:maven-artifact

[Error]
3.0
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    \- org.apache.maven.plugin-tools:maven-plugin-annotations:jar:3.6.0:provided
       \- (org.apache.maven:maven-artifact:jar:3.0:provided - omitted for conflict with 3.6.3)

3.6.3
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    +- org.apache.maven:maven-plugin-api:jar:3.6.3:compile
    |  \- org.apache.maven:maven-artifact:jar:3.6.3:compile
    +- org.apache.maven:maven-core:jar:3.6.3:provided
    |  +- (org.apache.maven:maven-artifact:jar:3.6.3:provided - omitted for duplicate)
    |  \- org.apache.maven:maven-model-builder:jar:3.6.3:provided
    |     \- (org.apache.maven:maven-artifact:jar:3.6.3:provided - omitted for duplicate)
    \- org.apache.maven:maven-compat:jar:3.6.3:provided
       \- (org.apache.maven:maven-artifact:jar:3.6.3:provided - omitted for duplicate)

org.codehaus.plexus:plexus-classworlds

[Error]
2.5.2
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    +- org.apache.maven:maven-plugin-api:jar:3.6.3:compile
    |  \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.4:compile
    |     \- (org.codehaus.plexus:plexus-classworlds:jar:2.5.2:compile - omitted for conflict with 2.6.0)
    \- io.takari.maven.plugins:takari-plugin-integration-testing:pom:2.9.2:test
       \- (org.codehaus.plexus:plexus-classworlds:jar:2.5.2:test - omitted for conflict with 2.6.0)

2.6.0
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    +- org.apache.maven:maven-plugin-api:jar:3.6.3:compile
    |  \- org.codehaus.plexus:plexus-classworlds:jar:2.6.0:compile
    \- org.apache.maven:maven-core:jar:3.6.3:provided
       \- (org.codehaus.plexus:plexus-classworlds:jar:2.6.0:provided - omitted for duplicate)

org.codehaus.plexus:plexus-component-annotations

[Error]
1.5.5
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    \- io.takari.maven.plugins:takari-plugin-integration-testing:pom:2.9.2:test
       \- io.takari.m2e.workspace:org.eclipse.m2e.workspace.cli:jar:0.4.0:test
          \- (org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:test - omitted for conflict with 2.1.0)

2.1.0
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    +- org.apache.maven:maven-plugin-api:jar:3.6.3:compile
    |  \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.4:compile
    |     \- org.codehaus.plexus:plexus-component-annotations:jar:2.1.0:compile
    +- org.apache.maven:maven-core:jar:3.6.3:provided
    |  \- (org.codehaus.plexus:plexus-component-annotations:jar:2.1.0:compile - scope updated from provided; omitted for duplicate)
    \- org.apache.maven:maven-compat:jar:3.6.3:provided
       \- (org.codehaus.plexus:plexus-component-annotations:jar:2.1.0:compile - scope updated from provided; omitted for duplicate)

org.codehaus.plexus:plexus-utils

[Error]
1.5.5
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    \- org.apache.maven:maven-core:jar:3.6.3:provided
       \- org.apache.maven:maven-settings-builder:jar:3.6.3:provided
          \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.4:provided
             \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:provided - omitted for conflict with 3.2.1)

3.0.17
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    \- org.apache.maven:maven-plugin-api:jar:3.6.3:compile
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.4:compile
          \- (org.codehaus.plexus:plexus-utils:jar:3.0.17:compile - omitted for conflict with 3.2.1)

3.0.21
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    \- io.takari.maven.plugins:takari-plugin-testing:jar:2.9.2:test
       \- (org.codehaus.plexus:plexus-utils:jar:3.0.21:test - omitted for conflict with 3.2.1)

3.2.0
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    \- org.apache.maven:maven-compat:jar:3.6.3:provided
       \- org.apache.maven.wagon:wagon-provider-api:jar:3.3.4:provided
          \- (org.codehaus.plexus:plexus-utils:jar:3.2.0:provided - omitted for conflict with 3.2.1)

3.2.1
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    +- org.apache.maven:maven-plugin-api:jar:3.6.3:compile
    |  +- org.apache.maven:maven-model:jar:3.6.3:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:compile - omitted for duplicate)
    |  +- org.apache.maven:maven-artifact:jar:3.6.3:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:compile - omitted for duplicate)
    |  \- org.codehaus.plexus:plexus-utils:jar:3.2.1:compile
    +- org.apache.maven:maven-core:jar:3.6.3:provided
    |  +- org.apache.maven:maven-settings:jar:3.6.3:provided
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:provided - omitted for duplicate)
    |  +- org.apache.maven:maven-settings-builder:jar:3.6.3:provided
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:provided - omitted for duplicate)
    |  +- org.apache.maven:maven-repository-metadata:jar:3.6.3:provided
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:provided - omitted for duplicate)
    |  +- org.apache.maven:maven-model-builder:jar:3.6.3:provided
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:provided - omitted for duplicate)
    |  +- org.apache.maven:maven-resolver-provider:jar:3.6.3:provided
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:provided - omitted for duplicate)
    |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:provided - omitted for duplicate)
    \- org.apache.maven:maven-compat:jar:3.6.3:provided
       \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:provided - omitted for duplicate)

org.slf4j:slf4j-api

[Error]
1.7.25
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    \- org.apache.maven:maven-core:jar:3.6.3:provided
       \- org.apache.maven.resolver:maven-resolver-impl:jar:1.4.1:provided
          \- (org.slf4j:slf4j-api:jar:1.7.25:provided - omitted for conflict with 1.7.29)

1.7.29
    com.github.ferstl:depgraph-maven-plugin:maven-plugin:4.0.1
    \- org.apache.maven:maven-core:jar:3.6.3:provided
       \- org.apache.maven:maven-resolver-provider:jar:3.6.3:provided
          \- org.slf4j:slf4j-api:jar:1.7.29:provided